# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:(?!cat).)*cat(?:(?!cat).)*)cat/\1Bull /gm;t' <<< "cat goose mouse horse pig cat cow"