use strict;
my $str = 'cat goose mouse horse pig cat cow';
my $regex = qr/^((?:(?!cat).)*cat(?:(?!cat).)*)cat/mp;
my $subst = '\\1Bull ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";