import re
regex = re.compile(r"^((?:(?!cat).)*cat(?:(?!cat).)*)cat", flags=re.MULTILINE)
test_str = "cat goose mouse horse pig cat cow"
subst = "\\1Bull "
result = regex.sub(subst, test_str)
if result:
print(result)