import Foundation
let pattern = #"^((?:(?!cat).)*cat(?:(?!cat).)*)cat"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"cat goose mouse horse pig cat cow"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1Bull "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)