$re = '/^((?:(?!cat).)*cat(?:(?!cat).)*)cat/m';
$str = 'cat goose mouse horse pig cat cow';
$subst = "\1Bull ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;