const regex = /^((?:(?!cat).)*cat(?:(?!cat).)*)cat/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:(?!cat).)*cat(?:(?!cat).)*)cat', 'gm')
const str = `cat goose mouse horse pig cat cow`;
const subst = `\1Bull `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);