# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[^\/])\n/, /gm;t' <<< "IMP007 - Verwijzende code onbekend[7]
IMP013 - Ziekenhuis registratienr dubbel[13]
IMP027 - De verrichting is niet gerelateerd aan de batch type[27]"