const regex = new RegExp('(?<=[^/])\\n', 'gm')
const str = `IMP007 - Verwijzende code onbekend[7]
IMP013 - Ziekenhuis registratienr dubbel[13]
IMP027 - De verrichting is niet gerelateerd aan de batch type[27]`;
const subst = `, `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);