use strict;
my $str = 'IMP007 - Verwijzende code onbekend[7]
IMP013 - Ziekenhuis registratienr dubbel[13]
IMP027 - De verrichting is niet gerelateerd aan de batch type[27]';
my $regex = qr/(?<=[^/])\n/mp;
my $subst = ', ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";