import re
regex = re.compile(r"(?<=[^/])\n", flags=re.MULTILINE)
test_str = ("IMP007 - Verwijzende code onbekend[7]\n"
"IMP013 - Ziekenhuis registratienr dubbel[13]\n"
"IMP027 - De verrichting is niet gerelateerd aan de batch type[27]")
subst = ", "
result = regex.sub(subst, test_str)
if result:
print(result)