# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{4})[\\/\-](0?[1-9]|1[012])[\\/\-](0?[1-9]|[12][0-9]|3[01])$/$3-$2-$1/;t' <<< "2015-03-12"