// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$").unwrap();
let string = "2015-03-12";
let substitution = "$3-$2-$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}