import Foundation
let pattern = #"^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015-03-12"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3-$2-$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}