using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$";
string substitution = @"$3-$2-$1";
string input = @"2015-03-12";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}