#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?P<specialities>(\d+)(,(\d+))*)\)"
Local $sString = "(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;" & @CRLF & _
"(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:" & @CRLF & _
"First trimester spontaneous abortion (before 20 wk) is most commonly due to:" & @CRLF & _
"blah (1,2,3)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")