import Foundation
let pattern = #"\((?P<specialities>(\d+)(,(\d+))*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
blah (1,2,3)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)