re = /\((?P<specialities>(\d+)(,(\d+))*)\)/
str = '(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
blah (1,2,3)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end