package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?P<specialities>(\d+)(,(\d+))*)\)`)
var str = `(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
blah (1,2,3)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}