import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?P<specialities>(\\d+)(,(\\d+))*)\\)";
final String string = "(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;\n"
+ "(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:\n"
+ "First trimester spontaneous abortion (before 20 wk) is most commonly due to:\n"
+ "blah (1,2,3)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}