// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((?P<specialities>(\d+)(,(\d+))*)\)").unwrap();
let string = "(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
blah (1,2,3)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}