using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?P<specialities>(\d+)(,(\d+))*)\)";
string input = @"(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
blah (1,2,3)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}