#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9]+([.+'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$"
Local $sString = "**Valid emails**: " & @CRLF & _
"test@gmail.com" & @CRLF & _
"test's@gmail.com" & @CRLF & _
"t@gmail.com" & @CRLF & _
"" & @CRLF & _
"**Invalid emails**: " & @CRLF & _
"'test@gmail.com" & @CRLF & _
"test'@gmail.com" & @CRLF & _
"'test'@gmail.com" & @CRLF & _
"test''s@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")