$re = '/^[A-Za-z0-9]+([.+\'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$/m';
$str = '**Valid emails**:
test@gmail.com
test\'s@gmail.com
t@gmail.com
**Invalid emails**:
\'test@gmail.com
test\'@gmail.com
\'test\'@gmail.com
test\'\'s@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);