package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]+([.+'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$`)
var str = `**Valid emails**:
test@gmail.com
test's@gmail.com
t@gmail.com
**Invalid emails**:
'test@gmail.com
test'@gmail.com
'test'@gmail.com
test''s@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}