import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9]+([.+'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\\.[_A-Za-z0-9-]+)*\\.[A-Za-z]{2,}$";
final String string = "**Valid emails**: \n"
+ "test@gmail.com\n"
+ "test's@gmail.com\n"
+ "t@gmail.com\n\n"
+ "**Invalid emails**: \n"
+ "'test@gmail.com\n"
+ "test'@gmail.com\n"
+ "'test'@gmail.com\n"
+ "test''s@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}