// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z0-9]+([.+'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$").unwrap();
let string = "**Valid emails**:
test@gmail.com
test's@gmail.com
t@gmail.com
**Invalid emails**:
'test@gmail.com
test'@gmail.com
'test'@gmail.com
test''s@gmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}