const regex = new RegExp('^[A-Za-z0-9]+([.+\\'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\\.[_A-Za-z0-9-]+)*\\.[A-Za-z]{2,}$', 'gm')
const str = `**Valid emails**:
test@gmail.com
test's@gmail.com
t@gmail.com
**Invalid emails**:
'test@gmail.com
test'@gmail.com
'test'@gmail.com
test''s@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}