using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9]+([.+'’_-][A-Za-z0-9]+)*@[_A-Za-z0-9-]+(?:\.[_A-Za-z0-9-]+)*\.[A-Za-z]{2,}$";
string input = @"**Valid emails**:
test@gmail.com
test's@gmail.com
t@gmail.com
**Invalid emails**:
'test@gmail.com
test'@gmail.com
'test'@gmail.com
test''s@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}