# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)/\2/gm;t' <<< "something else here
<!--
<Connector port=\"8443\" protocol=\"org.apache.coyote.http11.Http11NioProtocol\"
maxThreads=\"150\" SSLEnabled=\"true\" scheme=\"https\" secure=\"true\"
clientAuth=\"false\" sslProtocol=\"TLS\" />
-->
and here as well
"