// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)").unwrap();
let string = "something else here
<!--
<Connector port=\"8443\" protocol=\"org.apache.coyote.http11.Http11NioProtocol\"
maxThreads=\"150\" SSLEnabled=\"true\" scheme=\"https\" secure=\"true\"
clientAuth=\"false\" sslProtocol=\"TLS\" />
-->
and here as well
";
let substitution = "\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}