package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)`)
var str = `something else here
<!--
<Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" />
-->
and here as well
`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}