const regex = new RegExp('^(<!--.*\\R)(\\s+<Connector[^>]+>)(.*\\R-->.*)', 'gm')
const str = `something else here
<!--
<Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" />
-->
and here as well
`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);