#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)"
Local $sString = "something else here" & @CRLF & _
"" & @CRLF & _
"<!--" & @CRLF & _
" <Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"" & @CRLF & _
" maxThreads="150" SSLEnabled="true" scheme="https" secure="true"" & @CRLF & _
" clientAuth="false" sslProtocol="TLS" />" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"and here as well" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)