using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)";
string substitution = @"\2";
string input = @"something else here
<!--
<Connector port=""8443"" protocol=""org.apache.coyote.http11.Http11NioProtocol""
maxThreads=""150"" SSLEnabled=""true"" scheme=""https"" secure=""true""
clientAuth=""false"" sslProtocol=""TLS"" />
-->
and here as well
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}