use strict;
my $str = 'something else here
<!--
<Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" />
-->
and here as well
';
my $regex = qr~^(<!--.*\R)(\s+<Connector[^>]+>)(.*\R-->.*)~mp;
my $subst = '\\2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";