#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$"
Local $sString = "http://sites.google.com" & @CRLF & _
"https://192.168.0.1" & @CRLF & _
"www.google.com" & @CRLF & _
"http://google.com" & @CRLF & _
"ftp://user:password@www.example.com" & @CRLF & _
"news://www.example.com" & @CRLF & _
"http://www.test.com?pageid=123&testid=1524" & @CRLF & _
"http://www.⌘.ws/" & @CRLF & _
"http://www.foo.com/blah_blah_(wikipedia)" & @CRLF & _
"" & @CRLF & _
"http://www.test.com/?pageid=123&testid=1524" & @CRLF & _
"" & @CRLF & _
"http://www,google.com" & @CRLF & _
"http://w,google.com" & @CRLF & _
"http://q,google.com" & @CRLF & _
"" & @CRLF & _
"htftp://www.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")