# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$"
test_str = ("http://sites.google.com\n"
"https://192.168.0.1\n"
"www.google.com\n"
"http://google.com\n"
"ftp://user:password@www.example.com\n"
"news://www.example.com\n"
"http://www.test.com?pageid=123&testid=1524\n"
"http://www.⌘.ws/\n"
"http://www.foo.com/blah_blah_(wikipedia)\n\n"
"http://www.test.com/?pageid=123&testid=1524\n\n"
"http://www,google.com\n"
"http://w,google.com\n"
"http://q,google.com\n\n"
"htftp://www.google.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.