import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\\:\\/\\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\\-\\.]+\\.[a-zA-Z]{2,6}(\\:[0-9]{1,5})*(\\/($|[a-zA-Z0-9\\.\\,\\;\\?\\'\\\\\\+&%\\$#\\=~_\\-]+))*$";
final String string = "http://sites.google.com\n"
+ "https://192.168.0.1\n"
+ "www.google.com\n"
+ "http://google.com\n"
+ "ftp://user:password@www.example.com\n"
+ "news://www.example.com\n"
+ "http://www.test.com?pageid=123&testid=1524\n"
+ "http://www.⌘.ws/\n"
+ "http://www.foo.com/blah_blah_(wikipedia)\n\n"
+ "http://www.test.com/?pageid=123&testid=1524\n\n"
+ "http://www,google.com\n"
+ "http://w,google.com\n"
+ "http://q,google.com\n\n"
+ "htftp://www.google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}