use strict;
my $str = 'http://sites.google.com
https://192.168.0.1
www.google.com
http://google.com
ftp://user:password@www.example.com
news://www.example.com
http://www.test.com?pageid=123&testid=1524
http://www.⌘.ws/
http://www.foo.com/blah_blah_(wikipedia)
http://www.test.com/?pageid=123&testid=1524
http://www,google.com
http://w,google.com
http://q,google.com
htftp://www.google.com';
my $regex = qr/^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}