const regex = /^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\\:\\\/\\\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\\-\\.]+\\.[a-zA-Z]{2,6}(\\:[0-9]{1,5})*(\\\/($|[a-zA-Z0-9\\.\\,\\;\\?\\\'\\\\\\+&%\\$#\\=~_\\-]+))*$', 'gm')
const str = `http://sites.google.com
https://192.168.0.1
www.google.com
http://google.com
ftp://user:password@www.example.com
news://www.example.com
http://www.test.com?pageid=123&testid=1524
http://www.⌘.ws/
http://www.foo.com/blah_blah_(wikipedia)
http://www.test.com/?pageid=123&testid=1524
http://www,google.com
http://w,google.com
http://q,google.com
htftp://www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}