package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$`)
var str = `http://sites.google.com
https://192.168.0.1
www.google.com
http://google.com
ftp://user:password@www.example.com
news://www.example.com
http://www.test.com?pageid=123&testid=1524
http://www.⌘.ws/
http://www.foo.com/blah_blah_(wikipedia)
http://www.test.com/?pageid=123&testid=1524
http://www,google.com
http://w,google.com
http://q,google.com
htftp://www.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}