# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([^,]*),([^,]*)"/$1$2/gm;t' <<< "Day,Total,,,,,\"48,303\",100.00%,\"41,429\",100.00%,\"9,302\",100.00%,\"3,948\",100.00%
Day,\"Nov 11, 2014\",,,,,\"7,050\",14.60%,\"6,428\",15.52%,\"1,646\",17.70%,698,17.68%\""