use strict;
my $str = 'Day,Total,,,,,"48,303",100.00%,"41,429",100.00%,"9,302",100.00%,"3,948",100.00%
Day,"Nov 11, 2014",,,,,"7,050",14.60%,"6,428",15.52%,"1,646",17.70%,698,17.68%"';
my $regex = qr/"([^,]*),([^,]*)"/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";