const regex = /"([^,]*),([^,]*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^,]*),([^,]*)"', 'gm')
const str = `Day,Total,,,,,"48,303",100.00%,"41,429",100.00%,"9,302",100.00%,"3,948",100.00%
Day,"Nov 11, 2014",,,,,"7,050",14.60%,"6,428",15.52%,"1,646",17.70%,698,17.68%"`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);