#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"([^,]*),([^,]*)""
Local $sString = "Day,Total,,,,,"48,303",100.00%,"41,429",100.00%,"9,302",100.00%,"3,948",100.00%" & @CRLF & _
"Day,"Nov 11, 2014",,,,,"7,050",14.60%,"6,428",15.52%,"1,646",17.70%,698,17.68%""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)