$re = '/"([^,]*),([^,]*)"/m';
$str = 'Day,Total,,,,,"48,303",100.00%,"41,429",100.00%,"9,302",100.00%,"3,948",100.00%
Day,"Nov 11, 2014",,,,,"7,050",14.60%,"6,428",15.52%,"1,646",17.70%,698,17.68%"';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;