import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*? (?:VAN|VON|DE)) |((?<!^)\\G\\w+) ";
final String string = "ANNEKA VANHOVEN BAKKER\n"
+ "HENRIETTA VON DER GRAAF\n"
+ "CAROLINE VAN OOSTEN DE WINKEL\n"
+ "MARC DE VRIES VAN JONG\n"
+ "JOHN SMITH";
final String subst = "$1$2-";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}