re = /^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) /im
str = 'ANNEKA VANHOVEN BAKKER
HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
JOHN SMITH'
subst = '$1$2-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result