import re
regex = re.compile(r"^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) ", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("ANNEKA VANHOVEN BAKKER\n"
"HENRIETTA VON DER GRAAF\n"
"CAROLINE VAN OOSTEN DE WINKEL\n"
"MARC DE VRIES VAN JONG\n"
"JOHN SMITH")
subst = "$1$2-"
result = regex.sub(subst, test_str)
if result:
print(result)