$re = '/^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) /im';
$str = 'ANNEKA VANHOVEN BAKKER
HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
JOHN SMITH';
$subst = "$1$2-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;